Gimptalk - Premier Gimp Community: My First Tutorial - Blending Images in GIMP - Gimptalk - Premier Gimp Community

Jump to content

  • 10 Pages +
  • 1
  • 2
  • 3
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

My First Tutorial - Blending Images in GIMP

#1 User is offline   fencepost 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 2,646
  • Joined: 01-March 05

Posted 05 May 2005 - 03:52 AM

Hi, to all fellow GIMPTalk members. My name's Art and I've been using GIMP for about 3 months. I've found it to meet most of my needs and have had an absolute blast learning to use it.

Well, here's my first tutorial on blending images. Hope you like it. Sorry if it's too easy of a topic, but for what I want to create, it's essential!

Look forward to getting to know and learn from everyone.

Cheers.

Art

Keywords: Gimp, Blending, Feather, Images, Lasso, Selection

Posted Image

This is my first tutorial and, as a Newbie, I consider learning this step to be fundamental in helping me design message board signatures and wallpapers.
I know that blending of images can also be accomplished in numerous ways, but this tutorial will focus on the lasso tool and feathering. Hope this helps out other Newbies like myself. I apologize if it's too easy for most users.

I would like to say that the images and techniques were found on a Photoshop tutorial website. I had to modify their instructions slightly to work in the GIMP.

Let's begin!!

Open up your background image in Gimp.

Posted Image

Add a new layer (via cut/paste, rag/drop, etc.) of the layer you want to blend into the background.

Posted Image

With your lasso tool, enclose an area that you want to have blended. As you can see, the selected area doesn't have to be perfectly round. Now go to Select | Feather and enter a value. I used 25 for mine, but you can experiment. The higher the number, the smoother your selection will be.

Posted Image

Here's where the FUN begins. Now, Invert your selection (Ctrl-i) or go to Select Menu > Invert. Click the Delete Key for GIMP 2.4 users & Ctrl-K (Clear) for users of GIMP 2.2 and below. Your image will look like mine. If you continue to hit Ctrl-K, the edge of the selected area will continue to blend in.

Posted Image

Deselect your image and set the upper layer's blending mode to value and it looks like the images were meant to be together!

Posted Image

Cool, isn't it?!

Again, I hope this helped someone out. Comments are certainly welcome!

Art
0

#2 User is offline   Ali Imran 

  • Owner
  • Group: Administrators
  • Posts: 2,308
  • Joined: 06-December 04
  • LocationDubai, UAE

Posted 05 May 2005 - 04:30 AM

Amazing just amazing. Very accurate results.

I have been waiting for your first tutorial since the day you asked me th procedure to post a tutorial. btw, if you dont mind I will host the image on my server, it will be good becuase your server may go down, so there are no dead image, since your tutorial is compeltely based on single image.

And yes, most of poeple think the basic tutorials are not valuable, but as far I know on all of my network sites, most read tutorials are the basic ones with quick steps.

I highly appreciate your input. Waiting to see more.

regards
0

#3 User is offline   fencepost 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 2,646
  • Joined: 01-March 05

Posted 05 May 2005 - 01:28 PM

Hi, Ali.

I appreciate the feedback. I'm still working on my lightning tutorial so hopefully I can get it finished in the next couple of days. It's nothing earth-shattering, just a little different approach.

Quote

if you dont mind I will host the image on my server, it will be good becuase your server may go down, so there are no dead image, since your tutorial is compeltely based on single image.


Sure thing. That's a very good idea. It was a little time-consuming to prepare it as one image, but I like the overall way it turned out.

Looking for more good things around here.

See ya.

Art
0

#4 User is offline   Ali Imran 

  • Owner
  • Group: Administrators
  • Posts: 2,308
  • Joined: 06-December 04
  • LocationDubai, UAE

Posted 05 May 2005 - 08:06 PM

I will add a new LBCode (bbcode) which will allow users to add 2 column table in the post , which will be great for such tutorials which contain iamge with each step. An this way we would save our server space.

regards
0

#5 User is offline   codebox 

  • Retired Staff
  • PipPip
  • Group: Retired Staff
  • Posts: 72
  • Joined: 22-March 05

Posted 08 May 2005 - 05:05 AM

nice work man... pretty smoooth results...

keep it coming dude..! thanks.
0

#6 User is offline   BR7 

  • Member
  • PipPip
  • Group: Members
  • Posts: 569
  • Joined: 13-June 05

Posted 14 June 2005 - 07:59 PM

i got everything but couldn't figure out how to set blending mode I couldn't find it
0

#7 User is offline   Sean-Michael 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 1,587
  • Joined: 02-May 05

Posted 14 June 2005 - 09:25 PM

To set it to blend you...

[*]Goto the layers box and select the layer prepaired to blend

[*]In the layers box you will find a "Mode:" selection, set it to "VALUE"

Does this help?
0

#8 User is offline   BR7 

  • Member
  • PipPip
  • Group: Members
  • Posts: 569
  • Joined: 13-June 05

Posted 14 June 2005 - 09:47 PM

Posted Image

Is this right?
0

#9 User is offline   fencepost 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 2,646
  • Joined: 01-March 05

Posted 15 June 2005 - 01:30 AM

Hi, BR7. Welcome to the boards!

That is the right location, but for some reason you've only got one layer (the background) You should actually have 2 layers. When you brought in the second layer, did you anchor it to the background layer? If so, what you need to do is select the "new layer button" which is in the bottom left-hand corner of that same dialog box (The button that looks like a blank piece of paper with the corner turned down). This will place the new image on its own layer.

Another way to do the same thing is to go to the "New" menu and choose "Open as New Layer"

Now try the rest of the tutorial. That should work. Your upper layer should be set to "Value"

Let me know if you still have trouble.

Art
0

#10 User is offline   BR7 

  • Member
  • PipPip
  • Group: Members
  • Posts: 569
  • Joined: 13-June 05

Posted 15 June 2005 - 04:35 AM

Thanks for your help guys I really appreciate it like I said this is all new to me and you have been great.I finally got it because of your help :l:

Posted Image
0

#11 User is offline   NikeShox 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 20-June 05

Posted 20 June 2005 - 10:10 PM

Nice...but on v2.2, when you press the select tab there is no feath option...can you help?
0

#12 User is offline   renzoblade 

  • Member
  • PipPip
  • Group: Members
  • Posts: 49
  • Joined: 21-June 05
  • LocationSydney AUS

Posted 21 June 2005 - 03:45 PM

this really helped me since im new to gimp :w:
0

#13 User is offline   fencepost 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 2,646
  • Joined: 01-March 05

Posted 21 June 2005 - 06:47 PM

Quote

Nice...but on v2.2, when you press the select tab there is no feath option...can you help?


First of all, Welcome to the boards!

It's actually a menu option....At the top of the Gimp window there should be:

File-->Edit-->Select-->Other menus.

Does that help? If not, just post again and we'll get you set up!

Quote

this really helped me since im new to gimp


Welcome to the boards. Glad to be of help!

Art
0

#14 User is offline   Raven 

  • Member
  • PipPip
  • Group: Members
  • Posts: 25
  • Joined: 21-June 05

Posted 22 June 2005 - 03:01 PM

Umm...running into problems.

The first time I tried, the whole thing went SPLENDILY!


Thanks much for that....




But now...I am doing a grunge type signature for a friend.


I paste the image I want into the signature, I lasso it, and feather it. Now, whenever I press invert, it doesnt turn invisible like the other one did, it stays the same. And when I press Clear, the background turns either black or white, depending on what the starting background is. Im sure I'm following your tutorial.
0

#15 User is offline   fencepost 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 2,646
  • Joined: 01-March 05

Posted 22 June 2005 - 03:14 PM

Hi, Raven. Welcome to the boards.

Inverting shouldn't change the look of your image. The only function of invert is to invert the selection.

The only thing I can think of right off the bat is that the background might be the active layer and when you hit Ctrl-K (delete or clear), the background get deleted.

How about posting a screenshot of your layers dialog box exactly as you have it and also a screenshot of your image?

Thanks, Art
0

#16 User is offline   Raven 

  • Member
  • PipPip
  • Group: Members
  • Posts: 25
  • Joined: 21-June 05

Posted 22 June 2005 - 03:36 PM

I'll post it soon, have to get off for a couple hours.

I'll try what you said!
0

#17 User is offline   Raven 

  • Member
  • PipPip
  • Group: Members
  • Posts: 25
  • Joined: 21-June 05

Posted 22 June 2005 - 07:16 PM

Here:


Posted Image
This my background I plan on using.

Posted Image
This is after it is looped, and feathered.

Posted Image
This is after I invert the selection and hit clear.



Now, before, it just deleted the rest of the image, and kept that, so I could easily value the image into it. Now with the black, it wont work. I've tried this on many images.


Any Idea?
0

#18 User is offline   fencepost 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 2,646
  • Joined: 01-March 05

Posted 22 June 2005 - 07:36 PM

Yes, I do have an idea, but don't know if it's right or not....

Look at your second image (the one of the pasted image). You'll notice that on the right side of the image, there is a black border running from top to bottom (between the second image and the background image). Did you copy/paste this image in from another GIMP document? You may have pasted in a black background as well. So, when you delete the upper part, the only thing left is the black background.

I have no clue if this is correct or not, but what you need to do is crop the second image to the limits you need (exclude the black border). Save the image as a gif, png, jpg and then cut/paste the image in as a new layer or open it up as a new layer.

Try that and let me know your results.

Art

P.S. I'm not on a machine that has GIMP on it, so I can't verify your problem. This is all off the point of my head :w:
0

#19 User is offline   fencepost 

  • Retired Staff
  • PipPipPip
  • Group: Retired Staff
  • Posts: 2,646
  • Joined: 01-March 05

Posted 28 June 2005 - 03:05 PM

Raven,

I used the images you posted and had no problems getting them to blend. However, the one glitch I did encounter was by using a "round" or "circular" selection, the flames from the dragon's mouth turned a weird color with the blend mode set to "Value". None of the other blend modes would correct it.

A way around that problem was to actually follow the outline of the mouth more closely when making the selection. Unfortunately, if you want the flames to show up, that method won't work.

Anyone got a better solution?

A
0

#20 User is offline   jayli 

  • Member
  • PipPip
  • Group: Members
  • Posts: 11
  • Joined: 29-June 05

Posted 29 June 2005 - 06:33 AM

edit: Post deleted by fencepost
0

Share this topic:


  • 10 Pages +
  • 1
  • 2
  • 3
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic