Gimptalk - Premier Gimp Community: Install guide: Wacom drawing tablets with GIMP - Gimptalk - Premier Gimp Community

Jump to content

  • 10 Pages +
  • 1
  • 2
  • 3
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic

Install guide: Wacom drawing tablets with GIMP

#1 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 04 March 2007 - 02:27 PM

Installing Wacom tablets for use with GIMP
---------------------------------------------------------------

Introduction

This guide tries to help you getting your Wacom graphics tablet to work with GIMP. It is divided into parts.

First is a small intro on which tablet model to pick. This is of interest for people with any operating system (Linux, Windows, Mac).
The major part of the guide otherwise deals with installing Wacom drawing tablets for the Linux operating system. If you have Windows, the only section of interest for you is the last one; "Setting up GIMP" at the end of the guide. If you have a Mac, scroll to the last section Installing Wacom tablets for use with GIMP (Macintosh), written by staff member Cyrilshark (thanks!).

You might also be interested in reading the replies in this thread since eventual problems and solutions with tablets are being discussed there. A summary of some of the most useful ones (or notes of found bugs) can be found at the bottom of this document.


Which tablet to pick? (Linux / Windows / Mac)

This guide relates to the [Wacom] brand of tablets only. They are generally considered to make the best tablets and Wacom tablets are what most professional artists use as well. They are also the only ones you can expect to get to work under Linux with any certainty, through excellent Linux driver support.
That said, there are plenty of tablets brands out there that are a lot cheaper than the Wacom ones, and some people have been happy with those. Just remember that many of the pens in those have batteries that need recharging regularly, or even wires that can get in the way. The Wacom pens require no batteries and no wires. Anyway, if you go with another tablet brand you can't use this guide; you need to address your questions into our General Help forum and hope someone can help.

The Wacom line of tablets cover a wide range of models ranging from $100 (used) up to thousands of dollars. Which one to choose? Since this question has been asked of me so many times, I will try to make a recommendation here so I can refer to it. But do remember it is only my personal opinion.

Here we go: If you are looking to get your first tablet, get a Wacom [Bamboo] of the smallest (A6) size. That's right, that is the smallest and cheapest Wacom tablet you can get. Since you want to use it with GIMP you can do without the extra programs shipped with the "Fun" version and just get the plain tablet. In this case lowest price does not equal low quality. This one will last you forever.

Many ask why they should not get a bigger-size tablet, with more surface to draw on. Even if you can afford the bigger model I actually discourage this -- there is no need. Unless you are a real-life painter who is used to move your hands in large vivid motions, save your money (and wrists) and go with the smallest drawing surface. The resolutions of these tablets are so extreme that you will still have perfect control. If you want to move your brush over the entire canvas, that is what GIMP's zoom function is for anyway.

As for the higher-level professional tablets like the Wacom Intuos, you should remember that the step up from mouse to tablet is far larger than ever the step between different tablet models. Frankly I would still be using my entry-level Wacom tablet if it had not been so old its cable no longer fit my computer (it was not even an USB). Quite likely the Bamboo is the only one you'll ever need. Very few have actual need for the extra features of professional tablets, and if you ever do, you will already know enough not to have to read this guide about it ...

Now, assuming you have your tablet, let's move on.


Installing Wacom tablets under Linux

The linux distro you use changes the details of how things are installed, but mostly it should be the same. Linux fully supports most of the Wacom product line these days, including the newest pro tablets in the Intuous line. Pressure sensitivity (and tilt, rotation etc of a high-level tablet) ... all should work perfectly also under Linux. If it doesn't you just need to check some more things.

I'm running Debian here, but it's essentially the same for other distros. It used to be rather tricky to get the tablet to run, but these days it's really rather simple. You still need to know how to use the terminal to issue basic commands in Linux though. But as long as you can become root, can read and can use the cp command, you should be fine.

Wacom tablets running on Linux is a possibility because of the hard work of the [Linux-wacom project]. Bookmark that page, but for now the installation instructions on there is mostly for things you don't really have to do manually anymore (for those still running old Linux kernels). Read below instead for now, and remember that page if you need to troubleshoot in more detail later. They have much more detailed and general instructions than I can give, especially for different Linux distributions and bleeding edge versions of the driver.

You might want to jump back and forth between the various sections below in order to find the cause of problems for why your tablet is not working. For example the GIMP configuration section is at the end, and if your tablet is working normally except for pressure sensitivity in GIMP, that's maybe a good place to start. Just remember that the mouse cursor should move also without the pen tip actually touching the tablet. If you have to press down the tip to move the cursor, the tablet is in fact just working as a mouse and is not really installed at all.

Especially the sections Setting up the configuration of the tablet and Setting up GIMP are essential for proper function of the tablet in GIMP. So before giving up on any of the other steps, make sure these are done right or it won't work anyway.


Make sure you have a suitable Linux kernel

First of all, try to upgrade your linux kernel to at least version 2.6.18. Beginning with this kernel, much of the linux-wacom core drivers are already shipped within the kernel and don't have to be loaded or compiled separately as earlier. This helps, trust me, I've spent way too much time through the years compiling Wacom kernel modules. Anyway, by the time you read this, the stable linux kernel version is a lot higher than this so it should not be an issue. If you already has a suitable kernel, you can probably skip this section.

These days you don't need to recompile anything; a stock kernel 2.6.18 (or higher) works just fine. There should be a package in your distro for this. In debian you do (for example)
apt-get install linux-image

if you run a Pentium processor (your kernel version will likely be different by the time you read this).
(Do apt-cache search linux-image to find names of other kernel packages

(For other linux distros, use whatever package search you have available.)


Updating/installing your Linux Wacom driver

Hopefully no manual install should be needed anymore. Install the xserver-xorg-input-wacom package, or the equivalent package for XF86. Restart the x-server. That might well be all you need to do. Jump on to the next sections to test the tablet is recognized and configure your xorg.conf file properly. Jump back here only if things still does not work after all other steps.

If it still doesn't work, read on, you need to download the bleeding edge drivers directly from the developers.

Go to the linuxwacom homepage and download the newest package. You might want to play around with picking the "production" or the "development" version of these packages. For my dual-screen setup, my Intuous3 used to require the development package in order to work fully. Even if the following instructions doesn't work right away for you, actually picking a slightly older (and possibly more stable) version of this download might actually work better. Just keep that in mind.

OBS -- You need to be root from now on.

After you have downloaded, for example the linuxwacom-0.7.6-4.tar.bz2 archive, unpack it with
bunzip2 linuxwacom-0.7.6-4.tar.bz2
tar -xvf linuxwacom-0.7.6-4.tar

You want to save the resulting directory someplace. I have them in /usr/src .

The Linux-wacom package includes a lot of sources and ways to create the drivers manually. But since you have the 2.6.18 kernel installed you're hopefully not needing most of these things at all.
All you need is the latest driver, which you can find in your newly created directory under the prebuilt/ subdirectory. Run the install script. That both installs the driver wacom_drv.so and a set of small setup utilities useful for Wacom tablets. If that worked, jump to the next section, otherwise read on.

The driver's name is wacom_drv.so
The programs otherwise in the prebuilt/ directory are the "wacom-tools" mentioned elsewhere. They are good to have. Copy them to /usr/local/bin.

Now, install the driver. Simplest is to just copy wacom_drv.so to the right place on your hard drive.
Check if you have an older version already -- do locate wacom_drv.so. If you find one somewhere in the /usr/lib directory, that's the one you want to replace.

Common places to copy the driver to is
    [*:1nyf5eto]/usr/X11R6/lib/modules/input (for xfree86) or
    [*:1nyf5eto]/usr/lib/xorg/modules/input/ (for xorg)


Obs: As mentioned, it might actually be an idea to try out an older driver version as well, if all else fails.


Checking that the tablet is talking correctly to the Linux operating system

Disclaimer: Re-testing this section for myself, I found that the wacdump didn't output anything for me, despite the tablet working perfectly. I did get output when running the wacdump command from a terminal though (try Ctrl+Alt+F1 to bring up a terminal). Just so you don't panic if you see no results. If the tablet is working anyway, just don't worry about this section.

Check your tablet by running
wacdump /dev/inputs/XXX 
, where XXX is likely "wacom" these days, but can also be one of the other devices listed in the /dev/inputs drawer. If you didn't install the driver manually in the previous step, debian has a separate tool package named wacom-tools you have to install before getting the wacdump functionality.

The /dev/input directory is the gateway through which info from the tablet hardware (as well as other input devices such as mice, keyboard etc) enters the operating system. The wacdump takes a look at this input and shows you the values coming in. Pick a device then move your various input devices to see which one is measured by that device. The Wacom one will be easy to recognize since it also lists things like pressure and tilt etc. If you see stuff happening here, you know the device is feeding info to the OS properly. Now you just have to tell the OS (more specifically, the X-server) what to do with that info. Continue on to the next section.

Go to the linux-wacom homepage docs for further troubleshooting if the tablet doesn't work. Also try jumping back to the previous section to install an older/newer wacom_drv.so by downloading from the page. That might really be worth the trouble of trying.


Setting up the configuration of the tablet in Linux

This section is mandatory in order to get the tablet to work.

So the cursor is not moving, or it's moving and you have no pressure or tilt -- it's working mostly like a normal mouse? This is because the graphical x-server has no idea that the tablet is not a normal mouse but has all these cool features to take care of.

For this you need to configure your X-server config file. This you can find in either /etc/X11/xf86-conf or /etc/X11/xorg.conf depending on your x-server. Open this file in a text editor. Make a copy of it first, if you haven't done this before.

Now you go to the Linux-wacom docs [here] and put in those things they tell you put in the config file, just as it says. Note the different settings depending on if your pad is connected by USB cable or not (all new tablets are).

You will add at least a "stylus" device, an "eraser" device (these are the pen tip and back tip of the pen) as well as a "cursor" device (this is the separate Wacom mouse if you have it). If you have a Intuous3 there will be a "pad" device too. This is the buttons on the tablet.

Reboot the x-server. In your windows manager, you should now be able to move the mouse cursor by hovering the pen a little bit above the tablet (if you have to press down the pen to move the cursor it is not working correctly, go back to previous sections for troubleshooting). Pressing the pen down should also allow you to select, click&drag things in your window manager. If so, congrats, your pen is correctly installed. You can go to next section for some more configuration or directly to the last one to set up GIMP correctly.


Tweaking the pressure sensitivity (Linux)

You should probably wait with this step until you have set up GIMP correctly (last section), since it's hard to test pressure curves without painting on the canvas. Most likely the default will be ok for you until you are used to the tablet.

How pressure is applied to the brush in GIMP is determined by the tablet driver's pressure curve. This is simply a curve determining how the pressure is read depending on how hard you press. By default this is a linear curve, that is your pressure is exactly matched by the pressure as the tablet designers designed it. Depending on how light you are on the hand, you might feel that the tablet goes up to full pressure too fast. Or conversely you might think you have to press too hard to get full pressure.

Whereas Windows and Mac users should be able to set this sensitivity in their supplied tablet config program, Linux users should define this curve explicitly if they don't want the default linear behavour. There are a bunch of graphical tools to do it, but they are all just fancy ways to add stuff to your xorg.conf (or xf86.conf) file, so here is the "fool proof" way. Open your xorg.conf or xf86.conf file as before and find where you input your "stylus" and "eraser" input devices. I made a few presets. In each of these two devices, paste the following:
#  Option       "PressCurve"    "0,75,25,100"  #Softest curve (loose pressure)
#  Option       "PressCurve"    "0,50,50,100"
#  Option       "PressCurve"    "0,25,75,100"
#  Option       "PressCurve"    "0,0,100,100"  #linear curve (default)
#  Option       "PressCurve"    "25,0,100,75"
#  Option       "PressCurve"    "50,0,100,50"
#  Option        "PressCurve"    "75,0,100,25"  #firmest curve (hard pressure)

Remove the # in front of the line you want to use.
The "softer" the curve, the lighter you have to be on your hand. For example, I personally use a "firmer" pressure since I want to have to press pretty hard before I get the full pressure effect of the pen. In case you wonder how the values (each between 0 and 100) work, they describe the control points of a B├ęzier curve. Of course you can experiment with the values as you want to find the pressure curve that fits you best. Don't forget that you have to restart the Xserver before you see the difference in GIMP (see next section for setting up GIMP).


Setting up touch strip and pad (Linux)

You don't need to be root to set this part up.

If you have a tablet with buttons and a touchstrip on it (like e.g. the intuos tablets) you need to set these up for GIMP to use. First you must however have set up the "pad" device as described in the previous section. The theory from here on is simple -- the buttons as well as the touchstrip up/down events are mapped to normal keyboard keys, so that e.g. one of the buttons equals "Ctrl" and the "touchstrip up" event means the key "_" (or something). Afterwards all you need is to tell GIMP that Ctrl+_ means zoom or some other function to make it work.
So, how to map the pad to keyboard keys?

    [*:1nyf5eto]The first and older way is to use a little program called expresskeys -- http://freshmeat.net...comexpresskeys/. You run this from your home directory when your Xserver starts and it takes a small config file (located in ~/.expresskeys) that maps the keys to the pad. Download it and read the setup instructions. It's really easy.
    [*:1nyf5eto]With the linux-wacom diagnostic tools comes a program named xsetwacom (in debian, this tool is in the wacom-tools package). Since version 0.8.x or so, the Expresskey functionality has been integrated into this tool. When you have started your xserver, the following commands sets up the pad buttons of Wacom's Intuos3 tablet with one pad:
    xsetwacom set pad Button1 "core key shift"
    xsetwacom set pad Button2 "core key alt"
    xsetwacom set pad Button3 "core key control"
    xsetwacom set pad Button4 "core key space"
    xsetwacom set striplup "core key up"
    xsetwacom set stripldn "core key down"


You can use striprup and striprdn if you have a tablet with a right pad as well. I put these commands in my .bashrc file to have them run every time I start the xserver. Give the xsetwacom command on its own to see a list of all the commands you can give it and what they mean.


Setting tablet widescreen ratio (Linux)

Many Wacom tablets come in a 4:3 ratio active area, like the old monitors and TVs. Many monitors these days however come with a "wide" screen that may be 16:9 ("movie" widescreen) or 16:10 (for getting more work space on desktop). A tablet working in "Absolute" mode (which is really what you want) attempts to map the actual surface to a corresponding spot on the screen, and as you can imagine having different ratios between tablet and screen tends to distort things.

To test the distortion take a coin and put it on your tablet. Trace the coin with your pen. Is the result a perfect circle on screen? Most likely you will find that your widescreen monitor infact makes it into an squashed circle - an ellipse! It can help to setup GIMP first (see the section for that below), so you can see the circle you are trying to make.

It might be tempting to "learn" to work with this distortion. Don't. You'll just be learning bad habits. Instead the solution is to sacrifice a little strip of your tablet surface to make the tablet's ratio match the display ratio. The result will be a "dead" zone at the bottom of your tablet. It may sounds bad, but I can honestly say that even on the smallest tablet size (A6) which I'm currently using, the slightly smaller area is not something I notice at all (the non-working strip is about a centimeter or so tall).

Look up your "lines per inch" value for your particular tablet. For Wacom tablets this is often ridiculously high to achieve that extreme resolution. Multiply that with the size (in inches, yuck) to get the number of points in the X and Y direction of your tablet.

Now head into your Xserver config file again (see above on how to find that). You will want to add a new option to your "stylus" and "eraser" sections called BottomY:
Example for my tablet:
Option    "BottomY"   "16500" 

In the later versions of the driver you can also set BottomY with the xsetwacom program (a part of wacom-tools).

A bigger tablet will have larger numbers. The pixel Y coordinate is counted from the upper left corner of the tablet. BottomY effectively controls where the height of the tablet's "active" area ends. So a bigger BottomY value means a taller active area, whereas smaller will make it more and more "widescreen"-like.

You can calculate and try to figure out what BottomY value will result in a 16:10 or 16:9 tablet ratio. In practive I've found it just as well to just adjust a value then use the coin to draw a circle. If the circle is not a perfect circle on your monitor, adjust the BottomY value until the circle you make on the tablet is exactly reproduced as a circle also on the screen. Done!


-------------------------------------------------------------------------------------------

Setting up GIMP (Windows / Mac / Linux)

At this point you should have the tablet drivers and support programs installed, either by following the instructions above for Linux or by running the Wacom installation disk (Mac,Windows). Better yet, download the latest Windows/Mac drivers directly from Wacom's homepage [here]. If you run into trouble, also make sure you are updated with the latest operating system patches, directX and so on. Obviously you should also always run with the latest GIMP version.
If you use Windows/Mac, you might have gotten some simple test/config program supplied with the tablet. Test that and make sure the tablet is working with all its features. If it doesn't work there you can't expect it to work in GIMP either.

The final thing is to tell GIMP that you have this new cool tablet that you want to use. Go to Preferences->Input devices->Configure Extended input devices.

In the list you should be able to pick the various devices -- they are called
    [*:1nyf5eto] "stylus" (tip of your pen)
    [*:1nyf5eto] "eraser" (back tip of your pen)
    [*:1nyf5eto] "cursor" (the Wacom mouse if you have it)
    [*:1nyf5eto] "pad" (the buttons/slider on some tablets -- not all versions have them).
    [*:1nyf5eto] "puck" (not sure what heck this is, but some Windows users have reported seeing such a device name.)
[/list]
Windows/Mac users should have had these devices setup by the Wacom installer. Linux users can follow the instructions above to get everything working (For Windows users who do not see any tablet devices in this list, go to Preferences->Input Devices->Input Controllers and make sure "DirectX DirectInput" is in the "Active" collumn. Make sure you have the latest DirectX. You also have to restart GIMP).

Activate all devices (except the "pad") to mode "Screen", which seems to work best for most people. If you find that your cursor has a strange offset, try is to switch to the the "Windows" setting instead, your mileage may vary. Always leave "pad" disabled in the GIMP prefs, GIMP's not using it anyway and turning it on will only mess things up.

The pad buttons and eventual touch strips are instead linked directly to normal keyboard keys.
Under Windows or Macintosh the buttons/slider on the tablet (the "pad" device) setup is handled by the Windows/Mac driver installer and configuration program you get with the board. Linux users should refer to the relevant section above for information on how to set things up.

So to GIMP the tablet buttons and slider drags are just seen as any key press. Go into Preferences->Interface->Configure keyboard shortcuts and map those buttons to useful things. The "slider up/down" I have mapped to the keys ? and 0 for example, whereas the buttons means Ctrl, Space, Shift and Alt respectively. Then I just need to tell GIMP that e.g. Ctrl + ? means to zoom out, and then I will be able to do that directly from the tablet!

... And that's it. You should now have full pressure/tilt support in GIMP and full use of all features of your tablet. Remember that the "stylus" and "eraser" are treated as separate, equally worthy devices for GIMP (as opposed to how it's handled in PS) . This means that if you use either the pen or eraser tip to click on any tool, GIMP will assign the too to that particular tip. This means you can do interesting things like having your eraser tip act as a smooth tool instead of an eraser for example, and combine the two in any way you want. Just remember that using the mouse to choose the tool will not work, as that will only assign the tool to the mouse, not to the pen.

Good luck!

.
Griatch


---------------------------------------------------------------------------------

Installing Wacom tablets for use with GIMP (Mac)
By Cyrilshark

I will be posting a new part in to this tutorial for setting up a Wacom tablet using Mac OSX.
This part of the tutorial will be split in to four parts.

Part 1: Installing a driver.
Part 2: Setting up your tablet with the driver.
Part 3: Setting your tablet up with GIMP.
Part 4: Notes.

Part 1: Installing a driver.
First, you may ask "What's a driver?".
The answer is very easy. It's just a piece of software that tells your computer about the Hardware. (In this case, the tablet).
You need a driver for the tablet to work. If you bought your tablet and it didn't come with software, don't worry, theres an easy solution. So lets begin.

When you buy your tablet, it should come with a CD with a driver already on it. You simply have to install the driver. I didn't get my tablet with a driver, so I can't give exact instructions, but I assume it would be as easy as running the file on the CD once you put the CD in your computer.

Now, if you bought your tablet from say, a friend, and he couldn't find the software, don't worry, it's perfectly fine!
Just go over to Wacom.com, and follow the instructions below.

If you don't have the driver software:
First, as I said before, head over to Wacoms website. (http://www.Wacom.com). Select your region and language.
Find the "Downloads" button. It's located on the Navigation bar at the top.
Click on "Hardware Drivers". Select the appropriate tablet model and OS system. Download the latest driver.
Once you have finished downloading the .dmg file, it should automatically open the file.

Find "Install Wacom tablet.pkg". Run it. The driver should now be installed.

Part 2: Setting up your tablet with the driver.
Now we go on to part two...
Click on the Apple image in the top left of your screen, and click System Preferences.
Your driver should be installed, so find the "Wacom Tablet" image, and select it.
Now there should be three white boxes with options to add something, or remove it.
On the left of the three boxes, there should be some text. To the left of the first box, it should say "Tablet".
The second, "Tool", and the third, "Application". The third is the one we want. So click the plus sign
to the right of the box. Now a window to choose a application should pop up.

Navigate your way to X11.app, and select it. Now repeat that, but this time adding GIMP.app.
Now your tablet is programmed to be recognized in X11 and GIMP.

Part 3: Setting up your tablet in GIMP.
Now we come to the final part of this tutorial.
The first step is to open GIMP.
Now go to Edit>Preferences (in GIMP 2.6). It may be under File in previous versions.
Now click Input Devices. Now select "Configure Extended Input Devices".
It should now recognize your tablet if it didn't before you followed this tutorial.
Set the options to how you want them, and click "Save".

Close GIMP, and reopen it. Your tablet should now work!

Part 4: Notes

Make sure you have the right driver. This is something you NEED to double check, and double check again.
Make sure you have the latest version of GIMP. Later versions fix issues in regards to tablets on a Mac. (This was the solution to a user who sent me a message beacuse it wasn't working. Soon, he found out he just had to update GIMP.)

Check out this same tutorial in video.

http://www.youtube.c...h?v=mOikox-AZv4

I hope this worked for you! If you have any questions, post them here or
PM me (Cyrilshark) if you want.
------------------------------------------------------------------------------------------------


Troubleshooting (Notes from the thread):
Note that these will gradually go out of date or stop working as drivers/programs are updated

Pen cursor stuck to one side (Linux)

As of april 2010, I have some issues with the tablet cursor being stuck along the left side of the screen in Debian sid with Openbox. I find that it can be resolved by going into a terminal (Ctrl+Alt+F1), login as root and run wacdump /dev/inputs/wacom. Moving the pen on the tablet will show things happening, and when returning to X, the cursor works as it should - you only have to do this once as far as I can tell. You have to restart GIMP for the fix to register in the program though.

Tablet device not recognized (Mac)

At the time of writing, (jan 2009) some Mac users are reporting that the tablet devices (stylus, eraser etc) are not detected by GIMP despite the tablet being seen by other Mac-specific programs. Since GIMP is an X11 program (not native Aqua), it must be run from the X-server in Mac. It seems some(?) versions of MacOSX ships with an X-server that simply does not have its tablet support activated. So the problem is not GIMP's, but the Mac distribution itself. If anyone knows which MacOX versions are affected and how to solve the problem, let us know by replying to this thread.

euroshop said:

I was having this problem, and was able to solve it by updating to OS X 10.5.7 from 10.5.5, and then downloading a non-official but updated version of x11 (2.3.3) from here: http://xquartz.macos...wiki/X112.3.3.2


Cursor lockups and slowness (Windows)

There seem to still (aug 2008) be sporadic problems plaguing Windows users (only) of the Wacom Bamboo tablet with GIMP (GTK+ bug report is [here]). The problem manifests as the pen cursor behaving weirdly during use (see the thread for more info). The trouble is not affecting all Windows users, but you should at any rate always make sure you have the latest Wacom drivers (download them from Wacom's homepage) and the latest GIMP version. Make sure you have set everything up properly following the info above before assuming this is the problem. Ideally you should also test with another gfx program to see if the pen works ok there before deciding if the problem really lies with GIMP. Other operating systems than Windows are not affected.
A fix exists, and if you still face these problems you can correct them yourself. The original fix required hex-editing a .dll file (second quote below), but there now appears to also be a downloadable, already corrected .dll file available from some charitable user who has already done the work for you (first quote below). Don't forget to make backup copies before changing any files ... you never know.

Photocomix said:

Hy Griatch
i stumble over something that may be useful for Windows user
the problem , the bug is described here http://bugzilla.gnom...g.cgi?id=496958
A good new , is not needed manually edit the ddl, somebody already did and upload the patched dll here http://dump.bitplane...win32-2.0-0.dll

...In case the above download doesn't work out for you:

Grant said:

Griatch, I have located a way to fix the problems with my Wacom Graphire 4 tablet under Windows XP. This also appears to work with Vista according to the thread in the link i'll post below.

After using the method outlined in Thomas Bleekers instructions, now I can run both Gimp & Inkscape without any hanging cursors, improperly aimed cursors and proper pressure recognition.

It involves hex editing a file in the Gimp (and Inkscape if desired)

The instructions are given in the link below
and you need to have GIMP: 2.4.5 i686

http://bugzilla.gnom...i?id=496958#c24

Being an old fart, and complete noobie to anything like hex editing....I was pretty apprehensive at the thought of trying this. But it turned out to be fairly straight forward.

I hope this will work for people having problems with their Wacoms. But this could probably also break the program, so if you're at all unsure about trying this then don't do it!

Cheers

Grant


Tablet devices not detected by GIMP (Windows)

(nov 2009) For Windows users, if your tablet does not get detected by GIMP, the following might be worth trying:

garry.robbins said:

I upgraded to Gimp 2.6.1 on Windows XP, and although could use the stylus as a mouse, Gimp would not recognize it for other functions.
As others have reported, the "Configure Extended Input Devices" button said "No extended input devices".

Here is what I did to get it working:

* Cleared / reset all device settings
* Updated DirectX from the Microsoft site ( http://www.microsoft.com/downloads/deta ... layLang=en )
* In the Gimp Preferences, click on the Input Devices --> Input Controllers tab, and move "DirectX DirectInput" over to "Active Controllers", then restart Gimp.

Since the tablet appears to be under DirectX's control, you don't see it as an "Available Controller" directly?


thelackey3326 said:

I stumbled across this thread while trying to set up my Wacom Bamboo Pen & Touch tablet in Gimp 2.6.7 on Windows Vista Home Premium 64-bit (x64).

For those having problems with their Pen & Touch not being recognized as an Extended Input Device (you may be seeing the "No extended input devices" dialog), try starting Gimp with the pen instead of the mouse or touch pad, making sure the tablet is detecting the pen while it's starting up. My device has a white LED that changes to amber when it detects the pen. This has worked every time for me so far.

-Dean
g
0

#2 User is offline   Gutmanat 

  • Member
  • PipPip
  • Group: Members
  • Posts: 23
  • Joined: 21-June 07

Posted 10 July 2007 - 07:25 PM

Running Gimp 2.2.15 in WinXPHome. Have Wacom tablet CTE-430. When I try to follow your instructions GIMP preferences in the last section Wacom tablet Pressure Stylus the Axes tab is blank so what am I supposed to do?
Thanks,
Nathan
0

#3 User is offline   SummerStorms 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 26-August 07

Posted 26 August 2007 - 02:13 AM

I've got the same issue. Running Gimp 2.2.13 in WinXP and have a Wacom CTE-440. Everything's blank except for when I look at "Puck Transducer", whatever that is.
0

#4 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 26 August 2007 - 06:42 AM

@Gutmanat & SummerStorms

Since I don't use Windows myself, I can only speculate. But there have been others seeing only "Puck" as one of the devices for the Wacom Graphire 3 (also known as Sapphire or CTE-430/440? in different parts of the world I believe). The puck is (after a scan in Google) a sort of pointing device supplied with some Wacom tablets especially for CAD applications (it looks like a mouse but has a transparent window with a crosshair in it that allows precise pointing on a drawing or similar).

If you don't have such a puck and it's still showing up in devices, I'd say something is wrong with the Windows installation of your tablet.

GIMP can only see what is there. And in your case, this is supplied by Windows device drivers. If GIMP is fed no such info, or the wrong info it cannot do anything about it but accept it. So check your tablet installation.

Make sure that you have installed the latest drivers for your tablet (get them off the web at Wacom's homepage). Also test your tablet with the (eventual) graphics programs you got with the tablet to make sure that the tablet works in them (and that they work fully -- that is, pressure sensitivity, tool switch, eraser, tilt if you have it and so on). Then at least the driver is operational.

Also check Windows devices. I guess there must be a way to detect the various devices fed by the tablet in the device settings menu of Windows, but that's just a guess.

Get the latest GIMP. The latest stable version is 2.2.17. I don't think I've seen any mentions of updating the device sections (they are quite complete as it is), but you never know.

That's what I can come up with for now. As said I don't even use Windows myself. Try it out and see if you can track exactly where the problem is located.
.
Griatch
0

#5 User is offline   avaktar 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 26-August 07

Posted 26 August 2007 - 06:25 PM

Quote

@Gutmanat & SummerStorms

Since I don't use Windows myself, I can only speculate. But there have been others seeing only "Puck" as one of the devices for the Wacom Graphire 3 (also known as Sapphire or CTE-430/440? in different parts of the world I believe). The puck is (after a scan in Google) a sort of pointing device supplied with some Wacom tablets especially for CAD applications (it looks like a mouse but has a transparent window with a crosshair in it that allows precise pointing on a drawing or similar).

If you don't have such a puck and it's still showing up in devices, I'd say something is wrong with the Windows installation of your tablet.


Actually, it's Gimp's fault. This is the work-around for Gimp-2.2 in XP (using Intuos3 and latest 6.04-4 driver) to see all devices:

1. To get Gimp to see the puck, use the puck on the tablet to start GIMP. If your mouse isn't on the tablet when you start Gimp, it won't see it.
2. Set the puck aside. Using the Stylus, navigate to File -> Preferences -> Input Devices and click "Configure Extended Input Devices..."
3. Select "WACOM tablet Pressure Stylus" from the drop-down so that all the axes get filled in correctly.
4. Select "WACOM tablet Eraser" so its axes get filled in correctly.
5. Clicking "Save" does NOTHING. <--- BUG Therefore you have to do this every, single, time.

Also note that via the Intuos3 driver, it seems that you cannot set Gimp-specific tablet keys, and Gimp always takes whatever defaults you set up under "All Other".
0

#6 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 27 August 2007 - 09:59 PM

It sounds like an incompatability between the XP device announcement and GIMP's interpretation of the same. That it won't save is probably because next time you log in the device is not initially found which clears the save (it thinks it's a new device, not the one you saved earlier). You shouldn't have to "activate" devices physically for them to be detected.

It's still hard to tell if this is a GIMP internal flaw or rather XP doing something GIMP does not like. I've heard of many people using Intuos3 with GIMP under various flavours of Windows without problems. Make sure you have the latest of everything (including GIMP), that's all I can suggest. It seems mileage does indeed vary with the Windows version.
.
Griatch
0

#7 User is offline   ju^ju 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 11-September 07

Posted 11 September 2007 - 12:08 PM

Hi!

Unfortunately I can't get my WACOM Bamboo working correctly with GIMP under WinXP (SP2). The newest WACOM drivers are installed and it's working in every other application except GIMP. OK, I actually CAN get it working using the --ignore-wintab option, but I lose pressure sensitiviy and the tablet has a reduced resolution, that's not acceptable for me.

Seems that this is a problem related to GTK+, as I found users reporting the same problems (e.g. "jumping" cursor) with Inkscape. Is there any solution which lets me work with my Bamboo and GIMP under Windows? Please say there is one... :o:

Regards
Julian
0

#8 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 17 September 2007 - 09:44 PM

Which version of GIMP are you using?

As far as I know the Bamboo should be working like any other tablet; with full pressure sensitivity and resolution etc.

You mention a "jumping cursor", make sure the Device section in preferences is switched to Screen and/or Window depending on what you have now. Also, the action definitions (1-6 I think) is set to a default that usually works with how tablets send signals. But switching these around in the wrong way will do all sorts of crazy stuff to the cursor I've seen. Maybe the newest Wacom windows drivers assign these actions differently somehow, so that the GIMP default is no good? If nothing else works, it could be worth playing with.

I don't know for sure though, just some suggestions to test.
.
Griatch
0

#9 User is offline   ju^ju 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 11-September 07

Posted 18 September 2007 - 09:52 PM

I've tried various GIMP versions from 2.2 to 2.4. I played with the screen/window settings but it did not help. What do you mean by "action definitions"?

Sometimes the cursor "locks" when I move it over a GIMP window, sometimes it "works" but the brush tip and the cursor tip are not at the same spot but about 3-5cm apart.

It's a very strange behaviour and not really easy to describe. I have not experienced that in any other application yet...

edit: I installed GTK+ 2.10.11 now (instead of 2.10.13 delivered with GIMP). I'm getting a warning at GIMP start: in .../.gimp-2.2/devicerc "unexpected character `('", but the tablet works better. Cursor and brush are no longer apart but sometimes the cursor locks up.

Julian
0

#10 User is offline   Juggle4Evr 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 27-September 07

Posted 27 September 2007 - 03:23 PM

Hi,

I have also problems with Gimp 2.2.11 on MacOS with the Wacom Bamboo tablet. I have installed the delivered drivers and everything works with Photoshop Elements. But using Gimp I can not use the pressure sensitivity feature of the pen.
I followed the instructions as descriped in chapter "Setting up GIMP (Windows / Mac / Linux)" to setup Gimp for the tablet but Preferences->Input devices->Configure Extended input devices says "no extended input devices" .
Any idea what I can try else?

I don't really want to use Photoshop Elements instead of Gimp :-(

Bye,
Juergen
0

#11 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 27 September 2007 - 04:53 PM

@ju^ju

Interesting that rolling back the GTK version affects the behaviour to the better. The Cursor being separated from the brush has to do with the coordinate system of the device. This is handled by the Screen/Window setting, and changing that usually solves the issue. Do you use dual monitors? That's otherwise a good way to confuse GIMP/tablet, even though it can be resolved. Also check so you haven't defined some tablet aspect ratio in your tablet preferences (you can do that, for example to make the tablet "wide-screen" aspect, or split it into different areas) -- that could cause havoc for GIMP too I imagine, and it not really nessecary for normal tablet operations anyway (note that I'm not using Windows myself here, just extrapolating the stuff I can do with the Linux driver).

With the "action definitions" I meant the list of radio buttons below the Screen/Window button in the preferences. These defines axes 1,2 ... to each axis/button on the tablet. Normally you don't need to touch this, and if it works better for you now, that's not the problem; if those are wrong will have much more weird results than just an offset cursor.

@Juggle4Evr

First of all, make sure you get the latest GIMP. Current stable version is 2.2.17, yours is over a year old. Also make sure GTK+ is up-to-date and that you have the latest device driver for your tablet. When it says "no extended input devices" it means the tablet is not recogniced as a device resource for GIMP to use -- likely it tells GIMP it's just any common mouse -- in this case you can use pen as a normal mouse (i.e. move, click and so on), but it's not "extended", that is, there is no pressure sensitivity, tilt, etc. I don't know if there are any device issues on the Mac, but updating everything should at least increase the chances of the Bamboo (which is a very new tablet) being recogniced.
.
Griatch
0

#12 User is offline   Juggle4Evr 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 2
  • Joined: 27-September 07

Posted 27 September 2007 - 05:25 PM

I have my Gimp version from http://gimp-app.sourceforge.net/
This is the only source as far as I know where to get Gimp for MacOS without having to compile it. I'm not very firm with this self-compile stuff so I want to avoid that.
If you have any other source with a more recent verion for downloading an installable Gimp for MacOS please let me know.
0

#13 User is offline   PhotoComix 

  • GT Senior Moderator
  • Group: Senior Moderators
  • Posts: 11,288
  • Joined: 13-June 05

Posted 27 September 2007 - 06:34 PM

that is the right link
0

#14 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 28 September 2007 - 06:53 AM

Take a look at this thread, maybe it's of use for you on MacOS ...

http://www.gimptalk....-X-24710-1.html

.
Griatch
0

#15 User is offline   sobral 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 21-October 07

Posted 21 October 2007 - 07:59 AM

I don't know if it is the right place, but I have problems with my wacom bamboo tablet in windows. I did everything that is described but when I use it in Gimp, as in Inkscape, it works well, until I lift the pen more than 1 inch from the tablet, then it freezes, taking some attempts to come back to normal, and then it happens again.

I tried everything, (well, I hope not everything) to make it work, installing on other USB ports, I even tried to install on another computer and the problem remains.

If it works as a mouse, without pressure, it works fine. But as a pen, with pressure, it's always freezing in Gimp.

Do you have any ideas?
0

#16 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 01 November 2007 - 10:06 AM

@sobral

Sorry for the late reply, I've been on business in China for the last ten days.

So am I understanding you correct, using the pen as a mouse works, but when you try to full features, you cannot lift it away from the tablet lest it freezes -- and you have to try tapping the pen toward the tablet a few times for it to wake up again?

If I understood that right, it sounds like the driver is "releasing" the tablet in the wrong way when not used (i.e. you lifting the pen away from it). Have you tried getting the very latest Wacom driver from the Wacom homepage? Which version of GIMP are you using? 2.2.x or 2.4? It's not clear if there are any "new" tablet issues in 2.4 compared to 2,2.x yet, try both new and old version and see if it makes any difference.

I have seen several reports of trouble now from Bamboo users, but I thought that was mostly Linux issues. Please let me know if you get it to work and, if so, how.
.
Griatch
0

#17 User is offline   kamhungsoh 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 08-November 07

Posted 09 November 2007 - 02:28 AM

I've encountered the described problem using Vista Home Premium + Gimp 2.4 + Wacom Graphire tablet. The problem did not happen when I was using Windows XP + Gimp 2.2.

Symptoms:

The pointer works (including pressure sensitivity and eraser) when I start drawing and as long as I don't lift the pen off the tablet. When I lift the pen, the pointer can freeze. The pointer can also freeze if I change tools (e.g. Pen to Brush) using the keyboard shortcuts. To unfreeze the pointer, I use the mouse to move it to another window, then back to the GIMP canvas window. The problem also happens with Inkscape 0.45.1, so I suspect there's some incompatibility between the underlying GTK library and Vista. Gnome bug 322778 http://bugzilla.gnom...g.cgi?id=322778 hints at the problem.

My current workaround is to use the no-wintab command line option. Then Gimp and Inkscape have no problems but I can't use the eraser or pressure sensitivity features any more.

I'd be interested in any suggestions.
0

#18 User is offline   Griatch 

  • GT Administrator
  • Group: Administrators
  • Posts: 5,398
  • Joined: 27-November 06
  • LocationSweden

Posted 09 November 2007 - 12:27 PM

Thanks for the link to the bug report. Have you checked with your CPU load to see if the behaviour matches that reported in the comments to that bug? It would nevertheless be good to be able to tell people that it's a known bug that is being worked on.

Sometimes it's really nice to be running Linux.
.
Griatch
0

#19 User is offline   kamhungsoh 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 5
  • Joined: 08-November 07

Posted 11 November 2007 - 11:36 PM

The CPU load doesn't spike as described in the Gnome bug and the tracking problem still exists after I hide the rulers, so I don't think processor load is the problem. I mentioned that bug in case any one else knows how to configure pre-compiled versions of GTK in Windows, or knows of a more appropriate bug report in GTK.
0

#20 User is offline   Reubo 

  • Newbie
  • Pip
  • Group: Members
  • Posts: 1
  • Joined: 25-November 07

Posted 26 November 2007 - 12:01 AM

Okay, I just upgraded to GIMP 2.4.2 and my tablet isn't working with it. I have a Wacom Graphire4 and my OS is Windows XP Home Edition

My problem is that my tablet doesn't want to configure with the program no matter what. When I go to the "Configure Input Devices" and press "Configure Extended Input Devices" the GIMP doesn't detect my tablet at all... what should I do about this?
0

Share this topic:


  • 10 Pages +
  • 1
  • 2
  • 3
  • Last »
  • You cannot start a new topic
  • You cannot reply to this topic